Translating Graphics With Paint.NET
One smart person once said that "a picture is worth a thousand words". As a translator, I can say that this was an exaggeration. I
guess it should be something like "on average, a picture is worth a hundred words". Regardless of the actual word count, however,
even a few words on a picture are a big challenge for a translator because the translation process is entirely different from
translation of a text document.
In this article, you will learn how to use a free image editor called Paint.NET to translate graphics - regular image files (JPEG, PNG,
GIF, etc), images in PDF files, and graphics embedded in other documents (e.g. Microsoft Word documents, etc). It will also teach
you the principles you can apply with any other image editing software.

Alternatives to using an image editor
One of the common methods of translating graphics is to use your word processor directly. In summary, you create text boxes with
the translated text and position them over the original text. This method has several advantages: you use only one tool (i.e. the
word processor) and you can easily correct mistakes in the text at any point. However, there are disadvantages: text is difficult to
position precisely, it is very difficult to match background color of the text to the color on the original image, there are issues with
grouping objects together, etc.
For those of you who are happy using the above approach, bear with me: I hope that after you finish reading this article, you will be
able to use both approaches depending on the situation. For those of you who have never tried the above approach or think it is
difficult, you should find image editors a lot of fun. And hey, you will also learn how to create a postcard or what not!

Selecting the right tool
Selecting the right image editor is very important. For the purpose of this article, I selected a free program called 'Paint.NET'.
Although this program is free, it is very sophisticated and mature and is equally suited for simple and very complex image editing
tasks. If you are interested in other tools, check out a comparison matrix at the end of the article.
To install Paint.NET, download a latest version from the program's website. The installer will automatically download and install a
correct version of Microsoft .NET Framework which is required by the program. If you want to install Paint.NET on a computer with
an unreliable or non-existent internet connection, you will need to download Microsoft .NET Framework separately (the download
link is provided in the System Requirements section).

Translation workflow
We will use the following workflow to translate graphics:
1. Extract image from the document (skip this if you already have a file in a graphical format, e.g. JPEG, GIF, PNG, TIFF, BMP,
etc.) and open it in Paint.NET;
2. Create 2 new layers - one for hiding the original text (we'll call it the mask layer), and another one to hold all translated text
(the text layer);
3. Insert translation into the text layer;
4. Modify the mask layer to hide the original text and match the original text background;
5. Save the file in a graphical format and, optionally, Paint.NET native format (pdn);
6. Insert the file in the word processor, etc. (skip this step if the original file was already in a graphical format, e.g. JPEG, GIF,
PNG, TIFF, BMP, etc.)

Step 1: Extracting the image and opening it in Paint.NET
To transfer the image into Paint.NET:
If the image is stored in a Microsoft Office document (Word, Excel, Powerpoint, etc):
1. Select the image (click anywhere inside it);
2. Copy the image to the clipboard (Office 2003 or earlier: click Edit -> Copy; Office 2007 or later: click Copy from the
Clipboard group on the Home tab);
3. Open Paint.NET and create a new file by clicking File -> New...;
4. In Paint.NET, click Edit -> Paste to insert the image from the clipboard. If you see a prompt that the image is too
small, click 'Expand canvas'.
However, Microsoft would not be Microsoft if this method worked perfectly. Sometimes, the image will not get copied into
Paint.NET correctly. To fix this, follow this procedure:
1. Open Microsoft Powerpoint and click Edit -> Paste to insert the image from the clipboard (this time it will be inserted
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correctly);
2. Right-click the image and choose Save as Picture... from the pop-up menu;
3. Save the image in PNG or JPEG format (PNG format is better since there is no quality loss);
4. Open the file in Paint.NET (File -> Open... menu);
5. If you don't have Powerpoint, you can use Print Screen button on your keyboard to copy the entire screen to the
clipboard and then paste it into Paint.NET. Before you press Print Screen button, I would suggest to increase the
zoom ratio so that the image looks bigger than it actually is. This will allow you to increase the print quality of the
image in the translated document. When the image is pasted into Paint.NET, you will need to crop the screenshot
down to your image: use the Rectangle Select tool from the Tools panel to select the image on the screenshot, and
then click Image -> Crop to Selection.
If the image resides in a PDF file:
1. In Adobe Reader, click the image. The image should become selected (it will look shaded). You can also select an
area within the image;
2. Click Edit -> Copy to copy the image to the clipboard;
3. Open Paint.NET and create a new file by clicking File -> New...;
4. While in Paint.NET, click Edit -> Paste to insert the image from the clipboard. If you see a prompt that the image is
too small, choose 'Expand canvas'.
Note:
The above technique will not work if the PDF file is protected (in this case the Copy command on the Edit menu will be
disabled). Use the Print Screen button to copy the entire screen to the clipboard or request the image from your client.
If the image is stored in an OpenOffice document (Writer, Calc, Impress):
1. Select the image, right-click it and choose Save Graphics... from the pop-up menu;
2. Save the image in PNG or JPEG format (PNG format is better since there is no quality loss);
3. Open the file in Paint.NET (File -> Open... menu)
As an example, I have copied the following graphic from a TV manual in PDF format:

Figure 1: Original image extracted from a PDF

Step 2: Create new layers
Before we continue, let's talk a bit about layers. If you are not familiar with this concept (hey, you didn't even hear Shrek's famous
'onions and ogres' talk?), layers are used in most drawing programs to separate various types of graphical information and make
images more manageable. You can see layers in such popular programs as Adobe Photoshop, Autodesk AutoCAD, Corel
Photopaint, Paint Shop Pro, etc.
With layers, you can:
Store different types of graphical data in different layers (in our case we will have a background layer with the original
image, a mask layer hiding original text, and a text layer containing translated text);
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Change the order in which this graphical data is presented (in our case the text layer will be the top-most layer, with the
mask layer underneath, and the background layer at the bottom);
Show/hide certain data, etc.
In Paint.NET, you manipulate layers using the Layers panel (click Window -> Layers if you don't see it). Using the Layers panel,
you can add, delete, reorder, hide/show, rename, and merge layers.

Figure 2: Our image and the Layers panel
When you create a new image in Paint.NET, it has only one layer called 'Background'. All layers are created totally transparent at
first, so if you have something in the background layer and add 10 other layers above it, you will still see the background layer.
When you draw something in any of the layers, however, some of the things in the layers below will no longer be visible. We are
going to use this very principle: above the Background layer we will create another layer (called 'Mask') to hide the text in the
Background layer, and at the top we will create another layer (called 'Text') where we will put the translated text.
Now, let's create those 2 layers we were talking about:
To create a layer, click the small button with the green cross [see Fig. 2] or click Layers -> Add New Layer. The layer is
inserted above the current selected layer.
To change the position of the new layer, select the layer in the Layers panel and use Move Layer Up (
Layer Down (

) and Move

) buttons.

To give the new layers descriptive names, select a layer in the Layers panel and click the small button with a pencil [see
Fig. 2], double-click the layer or select Layers -> Layer Properties... menu.
Let's call the layer above the background layer 'Mask', and the layer above it - 'Text'.
When we are done, your Layers panel should look something like Figure 3 below:

Figure 3: Layers panel after adding 2 new layers
Note:
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Read the Advanced Techniques section for additional information on working with layers in some images.

Step 3: Inserting translation into the text layer
By now you are probably wondering: when am I going to do some translation? Well, we've prepared all the groundwork, so let's get
the show on the road!
Working with text is pretty easy:
1. Use the Color Picker tool to pick the correct text color from the original image in the Background layer;
2. Select the layer that you designated for text;
3. Choose the Text tool from the Tools panel and click within the image;
4. Enter text, trying to match the original text formatting closely;
5. Correct typos, inconsistencies, etc. during the proofreading stage.
Let's break down each of the steps above. As an example, we will be translating the word 'Internet' in our sample image:
1. Use the Color Picker tool to pick the correct text color from the image.
Before you add a text block, you need to tell Paint.NET what color it needs to use to format the text. Unfortunately, it is quite
difficult to change the text color when you have already typed some text, so we'll pick the right color before adding the text.
). Switch to the Background layer (this is
Select the Color Picker tool from the Tools panel (green eyedropper icon
where all the original colors are stored). To zoom in on a specific area, use the plus and minus buttons (
) on the toolbar or rotate the mousewheel up or down while holding the Ctrl key. Finally, click over
the color you would like to use for the text. The Colors panel should change to something like this:

Figure 4: Using the Color Picker to pick a color from the original image
Tips:
if the color of the text you are about to add is already present at the bottom of the Colors panel, you can just select
that color from there [see Standard / custom colors area in Fig. 4];
if your image has only a few colors and you need to translate a lot of text blocks, you can add all those colors to the
standard palette by picking a color with the Color Picker, clicking the button marked 'Add to palette' in Fig. 4, and
then clicking one of the colors in the standard colors area. This will allow you to choose those colors quickly.
2. Select the layer that we have designated for text
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As soon as you finish editing a text block in Paint.NET, that text 'overwrites' anything stored in the same layer (using the
graphical software terminology, the text is 'rendered' or 'rasterized'). This is why it is very important to choose the right layer
in the Layers panel before adding text. Remember: always make sure that you have chosen the correct layer (preferably the
layer designated for text) in the Layers panel, or you risk overwriting something (which you can always Undo, of course).
3. Make sure that nothing is selected within the image
When an area is selected (surrounded by a moving dotted line), the Text tool treats that area as a working area. In other
words, only the text located inside the selection will be visible.
If you type the text and don't see anything, do the following: choose Edit -> Deselect or click

on the toolbar.

4. Choose the Text tool from the Tools panel and click within the image.
Once you do this, you will see a blinking caret with a cross-shaped icon next to it.
Paint.NET always remembers the formatting that you used for the previous text block, so if you have 2 or 3 different types of
text formatting in the image, it is a good idea to add all text blocks with one type of formatting, then text blocks with another
type of formatting, etc.
5. Enter text, trying to match the original text formatting closely.
You can change the formatting of the entire text block at any time while you are editing it using the Text Tool's Properties
toolbar.

Figure 5: Text editing
You can also move the text around by dragging the cross-shaped icon in the bottom right corner of the text (press Ctrl key if
you can't see this icon).
The text editor in Paint.NET is pretty basic. If you make a typo, use the left/right keys to go back to the mistyped text, or click
the mouse where you want to modify something. To delete letters, press Delete or Backspace keys.
Check the text for typos, etc., and then position it right where you want to see it in the translated version (it will be above the
original text). Click outside the text block and it will become rendered on the current layer.
Tips:
You can also use the Colors panel to change the text color while the text is being edited;
Paint.NET does not support formatting of individual letters, so you will have to outsmart the program by creating
several text blocks;
To insert a special symbol (e.g. a degree or Euro symbol), use one of these methods:
insert the symbol in Microsoft Word or another word processor, copy it to the clipboard and press Ctrl+V key
combination to paste it in the text editor;
input the symbol using the numerical keypad located on the right side of your keyboard (this method works in
all text editors). For more information, please read this page.
6. Correct the text after it has been rendered
Suppose you made a typo in the word 'Internet' (that stupid keyboard!). To correct it, you need to erase the text and
type some new text instead. To do this:
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1. Select the layer where the text is actually stored (i.e. the Text layer);
2. Select an area around the text using the Rectangle Select tool (

):

Figure 6: Selecting with Rectangle Select tool
3. Press Delete key to erase everything within the selection;
4. To erase individual areas, select the Eraser tool (
) from the Tools panel, set the appropriate brush width
from the Eraser Properties toolbar, and make a couple of strokes over the text to erase it. I advise you to
make a selection first to avoid accidentally erasing some other text in the same layer.

Figure 7: Using the Eraser tool
5. Reset the selection by choosing Edit -> Deselect or clicking
on the toolbar. This step is important,
because if you leave an area selected, other operations you perform on the image will be constrained to that
selection.
If you want to move the text that has been rendered:
1. select the Text layer;
2. select the area around the text using the Rectangle Select tool (
3. select the Move Selected Pixels tool (

);

) from the Tools panel;

4. position the mouse cursor inside the selection, click the left mouse button and drag the selection to a new
place:

Figure 8: Using the Move Selected Pixels tool
Notes & tips:
If you would like to insert rotated text, read the Advanced Techniques section;
Sometimes you may insert text in a wrong layer. Unless this is the Background layer (in this case I would recommend you to
undo the last action), you can use the Rectangle Select tool (
) to select the area around the text, click Edit -> Cut,
select the right layer, and click Edit -> Paste. If you need to move the text, position the mouse cursor inside the selection,
click the left mouse button and drag the selection to a new place.

Step 4: Modifying the mask layer to hide the original text and match the original text background
So, we have finally translated the text, but the original text is still visible underneath our translation. We are now going to hide this
text by painting in the Mask layer (which is right between the Text layer and the Background layer).
To accomplish this:
1. Pick the background color of the text from the original image: select the Background layer, activate the Color Picker tool,
and click on the background of the original text to copy this color to the Colors panel;
2. Select the Mask layer in the Layers panel. Again, be careful not to select the Text or Background layer;
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3. Use the Rectangle Select tool (
) to make a selection around an original block of text. It is always recommended to make
a selection prior to using other tools to avoid overwriting something else located in the same layer;
4. Use one of the following actions depending on the background of the text:
If the text background is uniform, select the Paint Bucket tool (
current color:

) and click within the selection to fill it with the

Figure 9: Using the Paint Bucket tool to modify the Mask layer
If there are several colors in the text background, you will need to use the Paintbrush (
) or Pencil (
). Use the
Pencil to paint individual pixels with a specific color. The Brush is more versatile: you can change the size of the
brush, and use it to create blurred transitions with the original background color when the text background is
complex. Experiment with these tools to see the benefits of each one.

Step 5: Saving the file
So, congratulations! You are only a few moments away from putting the image in the translated document. We now need to save
the file in a format supported by your word processor.
Before we do this, it is a good idea to save the image in Paint.NET format. This way, you can make corrections to the image more
easily because the file saved in this format will contain all the layers you created. In Paint.NET, click File -> Save, select a folder to
save to, type the name of the image, and finally select "Paint.NET (*.pdn)" from Save as type list before clicking the Save button.
Now, let's save the image so that we could insert it in the translated document. Click File -> Save As... and choose "PNG" or
"JPEG" from Save as type list before clicking the Save button.
For a PNG file, you will see a Save Configuration dialogue. In this dialogue, choose "24-bit ", "32-bit" or "Auto-detect" and
click OK :
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Figure 10: PNG file settings
For a JPEG file, you will also see a Save Configuration dialogue. Select a high quality (90-95%) if the file size is not a
problem for you. Otherwise, play with the quality until the file size is small enough and the preview image is satisfactory.

Figure 11: JPEG file settings
When you press OK in the Save Configuration dialogue, you will see a dialogue asking you whether you want to "flatten" the
image. PNG and JPEG formats cannot store individual layers which you created, so all the layers need to be merged together. The
image will still look the same, but it will contain only one layer. Click 'Flatten' to save the image:

Figure 12: Flatten image prompt
Now, you will notice that the Layers panel now contains only one layer. At this moment, you can make further changes to the image
(open the PDN file you saved before, or undo the last action to 'unflatten' the image) or insert the PNG / JPEG image in the word
processor.

Step 6: Inserting the file in the word processor
As the last step, we will need to insert our image (which we now have in PNG or JPEG format) into the final document.
Microsoft Office document (Word, Excel, Powerpoint, etc):
Office 2003 or earlier: click Insert -> Picture -> From file...;
Office 2007 or later: click Picture from the Illustrations group on the Insert tab);
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OpenOffice document (Writer, Calc, Impress):
Click Insert -> Picture -> From file...

Advanced Techniques
In this section, you will learn some advanced techniques for translating images using Paint.NET.
Inserting rotated text
Sometimes you will need to translate rotated text (e.g. vertical text rotated at 90 degrees such as Y axis labels, etc.). Follow
the steps below to insert such text in your images:
1. Insert a new layer above the existing Text layer. It must be a new layer because we will need to rotate it.
2. Select the new layer and type the text in the middle of the image using the procedure explained in Step 3 above.
3. Click Layers -> Rotate / Zoom...
4. In the Rotate / Zoom dialogue, type 90 (for text which will be read from bottom to top) or -90 (for text which will be
read from top to bottom) in the Angle box and click OK :

Figure 13: Text rotated 90 degrees
5. select an area around the rotated text, then select the Move Selected Pixels tool (
drag the text to its new position.

) from the Tools panel, and

Working with transparent images
Sometimes when you open an image in Paint.NET or copy it from the clipboard, it will appear like this:

9 of 11

Figure 14: Transparent image example
The checkered background means that the image is transparent in those areas. If this is the case, follow this procedure:
1. Insert a new layer underneath 'Background' layer. To move the layer below the Background layer, select the new
layer and click Move Layer Down button (

) on the Layers panel until the layer is under the Background layer.

Figure 15: Layers panel for a transparent image
2. Select the new layer in the Layers panel and use the Paint Bucket tool (
) to fill the entire area with a White color
(for details on how to do this, read the sections below). The image background will become white.

Comparison of image editing software
Way back at the beginning of the article I promised to give you a comparison of some image editors. Well, here it is. It may be a bit
subjective, so I strongly encourage you to install these programs and see them for yourselves.
Paint.NET

Free, Windows

Rating - 6

Benefits:
Clean, intuitive interface
Drawbacks:
Text layers are not supported (i.e. you cannot modify text after it has been drawn, and such text overwrites other
things in the layer)
Basic text editor (only some keys may be used to edit text)
Small Caps, All Caps - not supported
Individual character formatting is not supported
Some advanced text formatting features (e.g. kerning) are not supported
Promises:
Text layers are promised in version 4.0. This will make it possible to modify text at any time
GIMP

Free, Windows / Linux

Rating - 5

Benefits:
Free open source application
Available for almost all known operating systems
Text objects are independent of their layer
The Text tool supports line spacing
Drawbacks:
Text layers are partially supported: they cannot be modified after being drawn, but unlike in Paint.NET they do not
overwrite the underlying image in the layer
Basic text editor (only some keys may be used to edit text)
Small Caps, All Caps - not supported
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Individual character formatting is not supported
Some advanced text formatting features (e.g. kerning) are not supported
Corel Paint Shop Pro X2

$39.99 USD, Windows, 30-day trial

Rating - 7

Benefits:
Text may be edited at any time
Rotate text easily
Some advanced text formatting features: letter spacing (kerning)
Drawbacks:
Individual character formatting is not supported
Rather basic text editor
Small Caps, All Caps - not supported
The program is optimized for photo editing, which makes it a bit difficult to use for translation
Adobe Fireworks CS4

$299 USD, Windows & Mac OS, 30-day trial

Rating - 10

Benefits:
Excellent text editor
Text can be modified at any time
Individual character formatting
Easily rotate text
A number of advanced text formatting features (line spacing, letter spacing, etc.)
Drawbacks: Virtually none
Verdict: If you need to translate a lot of images frequently, I strongly recommend to spend the money on Adobe Fireworks CS4 for
the speed and flexibility it will give you compared to other products. However, if you translate images from time to time, I would
recommend Paint.NET.
Congratulations!
You have just learnt how to use Paint.NET to translate graphics.
Although Paint.NET is somewhat different from other graphical editors, the techniques covered in this article work just as well in
other programs.
For your practice, use the following links to download Paint.NET and the image used in this tutorial:
Paint.NET installer [http://www.getpaint.net/download.html];
archive containing the image used for this tutorial in various formats [http://www.translatortools.net/articles/paintnet/using_paint-net_files.zip].

Link: http://www.translatortools.net/articles/paint-net.html
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